Referencing Water Right PODs in the Payette Subbasin to the NHD

using the Hydro Event Management (HEM) Tools (v 2.2).
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SETUP

1. Install HEM Tools (\\HEM Tool Training\HEM (v2.2).

2. Start ArcCatalog.
3. Add the HEM Toolbar to ArcCatalog (View -> Toolbars -> Hydro Event Management Tools).

]
I_==_|§§Z.E_I,,,.ﬁ.l:u:uut

4. Create new empty personal geodatabase on your hard drive and call it POD_HEM_EVENTS (or
you can pick a different name)

5. Single click the POD_HEM_EVENTS personal geodatabase you just created in the table of

contents, and then click the Event Featureclass Manager button =] on the HEM Toolbar.
Note: Dialog will be blank

6. Using the Event Featureclass Manager (Tools -> Add New), create an events feature class. Name
it. The rest of the settings should be similar to the dialog below. Click “Create New”.

Event Table Manager

Tools

Featureclass Name

POD_Point_Events

Geometry Type * Point " Line " Area
Schema Type * Ful " Only Reguired Fields
Mulbi-Raute Event r
Default Reach Resolution " Local  © Medium % High
Caontinuous Event r
EventType Domain Mone -
Configuration Keyword | J

7. Set the spatial reference
a. This will open the spatial reference dialog box.
b. Import the coordinate system of the NHD Flowline. The coordinate system should
match the system of the layer/network you are referencing to. Next through the
defaults (2 next, 1 finish).
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8. Close the Event Table Manager

9. Refresh (F5 or View>Refresh) and look at what you just created:
-] DaTa A

-3

+ Payette_IDTM.mdb

-5 POD_HEM_EVENTS.mdb
HEM_EVEMT_TABLES
HEMFeatureToMetadata
HEMMetadata
HEMMetadatalls
HEMSourceCitation
=] PoD_Point_Events Z

10. Close ArcCatalog
11. Start ArcMap and load the Hydro Event Manager toolbar. (View>Toolbars)
12. Add Data
a. The Entire NHD Database.
Note that the NHD database must have a geometric network.
When adding the NHD Database, you may see the dialog box

WErming; all

& selected item could not be added to the map
Item nok Found in this callection,

Say OK
b. Point Data you wish to reference to the NHD.
c. The Events feature class and tables you just created.

13. Click to the Display tab in the Table of Contents. Turn off and group NHD layers that are not
helpful with referencing. (Usually, the layers that are useful are the NHD flowline and the

Hydro_Net_Junction layers.)

14. Adjust the symbology of the layers added.
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15. Label the NHD Flowline with the GNIS name. Label the Point Data with attributes that can help

you reference it.
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16. You are able to transfer one attribute from the data point shapefile to the event database.
a. Open the point shapefile attribute table
b. Options>Add Field
c. Name the field DSCODE, Text, length:2

d. Populate this field with a two-digit code for each collection source, as follows:

Digitized Dz
GPS GP
Section SE
Q Q1
Qa Q2
QaqQ Q3
Blank XX

e. Create another field called “HEMCODE”

f. Options>Add Field
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g. Name the field HEMCODE, Text, length: 40

h. Calculate the HEMCODE field with a unique identifier. Concatenate the IDWR spatial
data ID, POD Source, and the newly created field, DSCODE:

Calculation: [sp_data_id] &" " & [Source] &" " & [DSCode]
i.e., “00001_PAYETTE RIVER_DZ”

i. Close the attribute table

17. On the Editor toolbar, Editor > Start Editing. Select the Personal Geodatabase that contains the
Event tables you set up earlier in ArcCatalog.

18. The Select Metadata Session dialog box may appear. If it doesn’t, on the HEM Toolbar > Edit
Tools > Metadata > Start Session

Hydro Event Management Tools 3]

Lt Task ICreate Point Event vI Target: IPOD_Point_Euents "I Edit Tools * Help

efadata Sessio L]

e [u] | Doy | ProcessDescrip... | ProcessDate | Attributefccura. .. | LogicalConsiste. .. | Completeness... | HorizPoszitio

»

4

19. Click on Create Button
20. Type in metadata information:
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f® Create Metadata Session

. Process Description  Other

Process Description Ince POD from IDVWR databasze to NHD Sftribute Accuracy Report

Contact Instructions Call between 5:00 and 1:00 P

|
Process Date I DSIEiDat; whenlthe process was completed, Fori I
—Cantact Information Complsteness Report [
Contact Organization | VR Horizontal Postional Accuracy |
Address Type I Physical and hailing “Yertical Postional Accuracy I
Address I 322 E. Front Street Metadata Standard MName I
City | Buoize Metadata Standard Yersion I
State or Province I D letadsta Date I 0503201 0
Postal Code | 53770 Dataset Credit [
Contact Telephaone I (208) 267 -4530 New DuulD: -1
|
|

Contact Email GlS @i idaho.gowv

Tip: Use CHI-E to open text editar for long text values.

T Source Citation

Q| Title SourceCitationdbkn Criginstar PuklicationDate BeginningDate EndingCrate Sourc

Create Source Citation m
Create Metadata Session

21. Click Create Metadata Session.
¥ 5ol stadata Sessio =

o[} | LD | ProcessDescrip... | ProcessDate | Aftributetccura... | LogicalConsiste... | CompletenessR.. | HarizPositio

22. Make sure the Metadata session you selected is highlighted. Click Select.

23. You are now ready to start creating Events!!
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CREATING POINT EVENTS FROM A POINT FILE

NOTE: If your ArcMap project, Point Events database, and metadata have already been set up;
Open ArcMap, Editor toolbar, Editor > Start Editing. Make sure your HEM toolbar Target is the
Point Events layer. HEM Toolbar > Edit Tools > Metadata > Start Session. Highlight the existing
Metadata record, & click “Select”.

=
8 Sele etadata Sessio L]

QD | DuulD Meta_ProcessiD rocessDescrip... | ProcessDate Attributeccurs.. | LogicalConsiste. . | CompletenessR .. | HorizPo:

4 4

1. Onthe HEM toolbar, set Task to Create Point Event and the Target to Point_Events:

Hydro Event Management Tools

k* ! Tazk: ICreate Peint Event j Target: IPDD_Poim_Euems j Edit Tools = Help

2. Go to Selection > Options (on main menu near the top of your screen) and set Selection
Tolerance. Set this value to 10 pixels. Click OK. You do not need to change this value during
different iterations.
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Selection Options

Interactive selection
R R N
wWhen vou select Features by dragging a biox with the Select Features

tool or Edit tool, or by using the Select By Graphics command, how do
wou want Features to be selected?

{* Seleck Features partially or completely within the box or graphicis)
™ Select Features completely within the bowx or graphicis)
(" Select Features that the box or graphic(s) are completely within

[v Clear the selection Far invisible layers when a new selection is made

Selection tolerance: | 100 pixels [éﬁ B » O F

Selection Colar

Choose the color wou want selected Features to be shown with by
default:

Warning Threshold

[v Display a warning when performing a 'Select All' or 'Switch Selection’
if the number of records is greater than this threshold:

Record Count = | 2000

[v Save layers with their current selections

(a4 | Zancel

3. On the Editor Toolbar, go to Editor > Options. Set Selection Tolerance to 10 pixels on the
General tab. Click OK. You do not need to change this value during different iterations.
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Editing Options

General lTopo\ogyl Versinning} Units ] Ed\tTasksl Annotalinnl Atlnbutes]

Display measurements using 3 decimal places
Snapping kolerance: | 10 ‘pixels ﬂ
Sticky move talerance: 0 pixels

[ Stretch geometry proportionately when moving a vertesx
[ Show snap tips
Stream Mode

Stream tolerance: 0 map units

Group 50 points together when streaming

oK. | Cancel Apply

4. Set the Snapping Environment
a. Editor toolbar, Editor > Snapping

b. Make sure that Vertex, Edge, and End are checked for NHD Flowline.

L4 x
Layer Wertex Edge End
mergel O O O
MHDPaink O O
HYDRO_MET _Junckic ] O O

[] [] []

O O O
NHDArea O O O
Subbasin O O O
Basin O O O
Region O O O
Subregion O O O
Subwatershed O O O
Watershed O O O
=[] Edit Sketch

[ Edit sketch vertices

[] Edit sketch edges

[] Perpendicular to sketch
=I-[] Topology Elements

[ Topology nodes
=[] Miscellaneous

[ survey Paints

Close the snapping environment

5. Inthe table of contents click once on the Import point Shapefile to highlight it (these are the
points that will be imported into the POD_POINT_EVENTS geodatabase).

6. Set the scale of your map; zoom out to a little larger than the full extent of your import dataset,
usually the subbasin boundary.
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7. Onthe HEM toolbar, click Edit Tools > Options. Click the Route Location Options tab and

populate as follows:

£l HEM Options (=]

Options

—Route Location Candidate Options
© Explicit

[ Only List Junctions (End Paoirts)
" Only List Mearest Point on Edges

[y Suppress the Candidate Form

—Route Location Default Suppr ion Method
ot

" Use Top of the Dovwnstream first, then uze Closest Candidate

¢ Use Closest Candidate first, then use Top of the Downstream

—Round Events
Events within tvwo measures of an endpoint will be rounded to the endpaint.

Ot

 on (events 0-2 will ke rounded to 0, 95-100 will be rounded to 100)

/ Apply and Close Reset to Defaults

8. On the HEM toolbar, click Edit Tools > Import Points

e L \

Hydro Event Management Tools

St mp @y kY @ Task Create Point Event VI Target:  |POD_Point_Events ~ | |Edit Tools = abao

\(\K\ \ KD} ¥ Clear HEM Elements

t- Snap Environmenk

\ >\ w F Select by Selected
nJ B Interactive Synchronize Events

. Batch Synchronize Events
@ Batch Synchronize Qa/QC

%

}8 Check Continuous Events
] Repair Continuous Events
/ ﬂ Impart Poinks

g Import Lines

f§ Import Areas

g Import Selected Flowlines

% Toqgle SourceFeaturelD

Metadata 4

Options
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9. If no features were selected in the Data Point Shapefile, you will see this dialog box:

HEM: Import Points

Mo selected Features For laver: Point_shapefile. Do wou want to import all poinks Fram this layer?

[}

10. Check to make sure that the layer is your original source points. If working in iterations, all
points should only be imported on the first iteration. On additional iterations, use a selections
unless the first iteration failed to import any points. Click Yes if first iteration.

11. Transfer the unique attributes from your Data Points Shapefile to the Point_Events Database:

Transfer IDs: Select Link Fields

Transfer IDs to Event Festureclass

Zelect Field to Calculste 1Dz From:
HEMCODE j

Zelect Field to Calculste 1Dz Into:;

[

Add ID's Don't Add IDs Stop Import

12. Click “Add ID’s”.
13. The program will run.

14. If more than one NHD feature should fall within the search tolerance of a point, a dialog box will
appear. If this dialog box appears, select the top record and say “OK” (see step 5).
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Select Route Location
Select a Candidate:

Mare than one feature is within the search tolerance.
Pleaze =zelect which gecometry wou waould like the input
paint ta =nap ta.

T end of Reachcode = 17050122001 415 ComiD = 52251078
Mearest point on Reachcode = 17050122001 415 ComlD = 52251078
T end of Reachcode = 170301 22006275 ComiD = -505

Mearest paint on Reachcode = 170501 22005275 ComiD = -505
FROM end of Reachcode = 17050122000574 ComliD = 52249054
Mearest point on Reachcode = 170501 22000374 ComlD = 52249054
FROM end of Reachcode = 170501 22006275 ComlD = -506

T end of Reachcode = 170301 22006275 ComiD = -506

Mearest paint on Reachcode = 170501 22006275 ComiD = -506

n Zoom to Feature Flash Feature

15. Select the top record and say OK. Do not Zoom to Feature.

16. A report will be generated showing how many point features have successfully been
transformed into events.

HEM: Import Points

:mport Paoints Results A

Fratn Festurelayer: POD_Sample_Data
To Festureclass; POD_Point_Events

Successiully imported: 3

Failed to import: 39
Frotm CICx:
Froem CICx:
Fram CiC:
Froem CICx:
Fram CiC:
Frown il

LI S R |

Save Report to File

17. When finished. Editor Toolbar, Editor > Save edits. Stop Editing.
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