Referencing Parcel Centroids to the NHD using HEM Tools
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SETUP
1. Install HEM Tools (\\HEM_Tool_Training\HEM_2_2a_Test_Version) if it is not available.

2. Start ArcCatalog.
3. Add the HEM Toolbar to ArcCatalog (View -> Toolbars -> Hydro Event Management Tools).

A
Eg.%ﬁbuut

4. Create new empty personal geodatabase on your hard drive and call it POD_HEM_EVENTS (or
you can pick a different name)

5. Single click the POD_HEM_EVENTS personal geodatabase you just created in the table of

contents, and then click the Event Featureclass Manager button =] on the HEM Toolbar.
Note: Dialog will be blank

6. Using the Event Featureclass Manager (Tools -> Add New), create an events feature class. Name
it. The rest of the settings should be similar to the dialog below. Click “Create New”.

Event Table Manager

Tools

Featureclass Name

POD_Point_Events

Geometry Type * Point " Line " Area
Schema Type * Ful " Only Reguired Fields
Mulbi-Raute Event r
Default Reach Resolution " Local  © Medium % High
Caontinuous Event r
EventType Domain Mone -
Configuration Keyword | J

7. Set the spatial reference
a. This will open the spatial reference dialog box.
b. Import the coordinate system of the NHD Flowline. The coordinate system should
match the system of the layer/network you are referencing to. Next through the
defaults (2 next, 1 finish).
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8. Close the Event Table Manager

9. Refresh (F5 or View>Refresh) and look at what you just created:
-] DaTA -
-3
+ Payette_IDTM.mdb
--f5) POD_HEM_EVENTS.mdb
HEM_EYEMT_TABLES
HEMFeatureToMetadata
HEMMetadata
HEMMetadatalls
HEMSourceCitation
=] PoD_Point_Events Z

10. Close ArcCatalog
11. Start ArcMap and load the Hydro Event Manager toolbar. (View>Toolbars)
12. Add Data
a. The Entire NHD Database.
Note that the NHD database must have a geometric network.
When adding the NHD Database, you may see the dialog box

WErming; all

& selected item could not be added to the map
Item nok Found in this callection,

Say OK
b. Point Data you wish to reference to the NHD.
c. The Events feature class and tables you just created.

13. Click to the Display tab in the Table of Contents. Turn off and group NHD layers that are not
helpful with referencing. (Usually, the layers that are useful are the NHD flowline and the

Hydro_Net_Junction layers.)

14. Adjust the symbology of the layers added.

3|Page BID HEM Documentation



15. Label the NHD Flowline with the GNIS name. Label the Point Data with attributes that can help
you reference it.
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16. You are able to transfer one attribute from the data point shapefile to the event database. If
there is not a unique value attribute field already in the data point shapefile, create one.

a. Open the point shapefile attribute table
b. Options>Add Field
c. Name the field Name_Ungq, type:Text, length: 50

d. Calculate the field with a unique identifier. One way is to concatenate Name with the
FID or ObjectlID.

e. Close the attribute table
17. Open the Point_Events attribute table:

a. Options>Add Field. Name the field Name_Unq, type:Text, length: 50 or match the
name, type and length of the existing unique attribute in the point shapefile.

b. Options>Add Field. Name the field SelectTol, type: Long Integer, length: 0.
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18. Set up a Relate from the Point_Events attribute table.

a. Options>Joins and Relates>Relate

Haliiis ﬂ‘

Felate lets pau associate data with thiz layer. The associated data isn't
appended into thiz laver'z attibute table like it iz in a Join. Instead you
can access the related data when you work with thiz layer's attributes or
VicE-yerza.

E stablishing a relate s particularly usetul if there iz a 1-to-many or
rary-ta-many association between the layer and the related data.

1. Chooze the field in thiz layer that the relate will be based on:

| Mame_JHE j

2. Chooze the table or layer to relate to this layer, or load from disk:

K} Diversionss ﬂ ﬂ

3. Chooze the figld in the related table or layer to baze the relate on:

|Name_LING |

4. Chaoose a name far the relate:

|F|e|ate1
About Relating D ata Cancel
b.
c. Relate the 2 unique fields together. The layer selected in step 2 is the point data.
d. OK

e. Close the attribute table.

19. On the Editor toolbar, Editor > Start Editing. Select the Personal Geodatabase that contains the
Event tables you set up earlier in ArcCatalog.

20. The Select Metadata Session dialog box may appear. If it doesn’t, on the HEM Toolbar > Edit
Tools > Metadata > Start Session

Hydro Event Management Tools

nr B & Tazk

Create Point Event ﬂ Target:  |POD_Point_Fuents ﬂ Edit Tools * About

5|Page BID HEM Documentation



efadata Sessio L]

e [u] | Doy | ProcessDescrip... | ProcessDate | Attributefccura. .. | LogicalConsiste. .. | Completeness... | HorizPoszitio

21. Click on Create Button
22. Type in metadata information:

f® Create Metadata Session

. Process Description  Other

Process Description Ince POD from IDVWR database to NHD Atribute Accuracy Report

I PP

Date when the process was completed, Fort

Process Date

Contact Instructions Call between &00 and 1:00 Pk

—Cortact Information Completeness Report [
Contact Organization | VR Horizontal Postional Accuracy I
Address Type | Physical and hailing wettical Postional Accuracy I
Address I 322 E. Front Strest Metadsta Standard Mame I
City | Buoise Metadata Standard Wersion I
State or Province I D hetadsta Date I 05i02i201 0
Postal Code | 83720 Dataset Cradit |
Contact Telephone I (208 287-4830 New DuulD: -1

Contact Email GlSEidwr idaho.gov

Tip: Use Crl-E to open text editor for long text values.

T Source Citation

Qi | Title SourceCitstionAbbi| Originator | PublicationDste | BeginningDate | EndingDate | Sourc

Create Source Citation m
Create Metadata Session

23. Click Create Metadata Session.
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X E1E Eldidid E 0 L]

QD | DD ProcessDescrip.. |Pru:u:esstﬂe Aftribtelcoura... |LDgicaICDnsiste... |Completenessﬁ... HarizPositio

24. Make sure the Metadata session you selected is highlighted. Click Select.

25. You are now ready to start creating Events!!
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CREATING POINT EVENTS FROM A POINT FILE

If your ArcMap project, Point Events database, and metadata have already been set up; Open
ArcMap, Editor toolbar, Editor > Start Editing. Make sure your HEM toolbar Target is the Point

Events layer. HEM Toolbar > Edit Tools > Metadata > Start Session. Highlight the existing
Metadata record, click Select.

1. Onthe HEM toolbar, set Task to Create Point Event and the Target to Point_Events:

Hydro Event Management Tools

ur G ! Task: ||’:|e:|te Point Event ﬂ Target: |PDD_Point_Euents ﬂ Edit Tools  About

Go to Selection > Options (on main menu near the top of your screen) and set Selection

Tolerance. Set this value to 10 pixels. Click OK. You do not need to change this value during
different iterations.

Selection Options

Interactive seleckion
B
\When yaou select Features by dragging a bax with the Select Features
tool or Edit tool, or by using the Select By Graphics command, how do
wou want Features to be selected?

{* Seleck Features partially or completely within the box or graphicis)
(" Select features completely within the box or graphicis)
(" Select Features that the box or graphic(s) are completely within

[v Clear the selection Far invisible layers when a new selection is made

Selection tolerance: |10 pixels [éﬁ B » O F

Selection Colar

Choose the color vou want selected Features to be shown with by
default:

Warning Threshold

[v Display a warning when performning a 'Select AlI' or 'Switch Selection’
if the number of records is greater than this threshold:

Record Count = | 2000

[v Save layers with their current selections

(a4 | Zancel

3. On the Editor Toolbar, go to Editor > Options. Set Snapping Tolerance to 10 pixels on the
General tab. Click OK. You do not need to change this value during different iterations.
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Editing Options

General lTopo\ogyl Versinning} Units ] Ed\tTasksl Annotalinnl Atlnbutes]

Display measurements using 3 decimal places
Snapping kolerance: | 10 ‘pixels ﬂ
Sticky move talerance: 0 pixels

[ Stretch geometry proportionately when moving a vertesx
[ Show snap tips
Stream Mode

Stream tolerance: 0 map units

Group 50 points together when streaming

oK. | Cancel Apply

4. Set the Snapping Environment
a. Editor toolbar, Editor > Snapping

b. Make sure that Vertex, Edge, and End are checked for NHD Flowline.

L4 x
Layer Wertex Edge End
mergel O O O
MHDPaink O O
HYDRO_MET _Junckic ] O O

[] [] []

O O O
NHDArea O O O
Subbasin O O O
Basin O O O
Region O O O
Subregion O O O
Subwatershed O O O
Watershed O O O
=[] Edit Sketch

[ Edit sketch vertices

[] Edit sketch edges

[] Perpendicular to sketch
=I-[] Topology Elements

[ Topology nodes
=[] Miscellaneous

[ survey Paints

Close the snapping environment
5. Inthe table of contents click once on Data Point Shapefile to highlight it.

6. Set the scale of your map to 1:1000.
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File Edit View Bookmarks Insert Selection Tools Window Help

DEHESE ic] ' # [1:1.000 R OR - Y=o

7. On the HEM toolbar, click Edit Tools > Import Points

[
Hydro Event Management Tools

nr IEI? , Task: |Creme Point Event ﬂ Target: ‘POD_Poim_E\rems

\(\ KD ¥ Clear HEM Elements
‘) t- Snap Environmenk
B Interactive Synchronize Events

N

%

. Batch Synchronize Events
@ Batch Synchronize Qa/QC
}8 Check Continuous Events

b A

] Repair Continuous Events

'_ Impart Poinks

g Import Lines
f§ Import Areas
/ g Import Selected Flowlines
t

% Toqgle SourceFeaturelD

#
#
" F Metadata 4
A [
b Cptions

LS -'..’f'/ ' \@
o

8. If no features were selected in the Data Point Shapefile, you will see this dialog box:

HEM: Import Points

Mo selected Features For laver: Point_shapefile. Do wou want to import all poinks Fram this layer?

[}

9. Check to make sure that the layer is your original source points. If working in iterations, all
points should only be imported on the first iteration. On additional iterations, use a selections
unless the first iteration failed to import any points. Click Yes if first iteration.

10. Transfer the unique attributes from your Data Points Shapefile to the Point_Events Database:

EEl Transfer IDs: Select Link Fields

Tranzfer IDz to Event Featureclass

Select Field to Calculate IDs From:
SHAPE _fid |

Select Field to Calculate D Into:

[~
Add ID"s Don‘t Add IDs Stop Import
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11. Click “Add ID’s".
12. The program will run.

13. If more than one NHD feature is within the search tolerance of a point, a dialog box will appear.

Select Route Location E”E”E'
Select & Candidate:

Wore than one feature is within the search tolerance.
Pleaze =elect which geometry wou wauld like the input
paint to =nap to.

T end of Reachcode = 17050122001 415 ComiD = 52251078
Mearest point on Reachcode = 17050122001 415 ComlD = 52251078
T2 end of Reachcode = 170501 22006275 ComlD = -505

Mearest point on Reachcode = 170501 22005273 ComlD = -5035
FROM end of Reachcode = 17050122000574 ComiD = 52249054
Mearest point on Reachcode = 170501 22000374 ComlD = 52249054
FROM end of Reachcode = 170501 22006275 ComlD = -506

T2 end of Reachcode = 170501 22006275 ComiD = -506

Mearest paint on Reachcode = 170501 22005275 ComiD = -506

n Zoom to Feature Flash Feature

14. Select the top record and say OK. Do not Zoom to Feature.

15. A report will be generated showing how many point features have successfully been
transformed into events.

HEM: Import Points

:mport Paoints Results ~

Fratn Festurelayer: POD_Sample_Data
To Featureclass: POD_Poirt_Events

Successfully imported: 3

Failed to import: 39
From CIC: 0
Froem Q0 1
Fram CIC: 2
From CIC: 3
From CIC: 4
From Cirr 5

Save Report to File

4

16. Open the Point_Events attribute table and field calculate the Select_Tol to 1000.
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a. Select the newly imported records.

b. Use the field calculator to calculate on the selected records.

17. Use the relate to select the points in the point shapefile that failed to import.

Select all records in the event table.

o

b. Inthe Point_Events attribute table: Options>Relate, Relatel

c. Open the attribute table of the Points Shapefile. Several Records should be selected. If
you compare the Name_Unq fields in both attribute tables, the selected records should
match.

d. Inthe attribute table of the Points Shapefile, Options> Switch Selection. You now have
selected the records that need to be imported at the next scale value.

e. Close tables

18. Repeat Steps 5 through 15 changing the scale by a factor of 5 each time. (1:1000, 1:5,000,
1:25,000, 1:125,000, 1:625,000, 1:3,125,000) until all points are referenced. (Don’t forget to set
the Select_Tol appropriately.)

19. When finished. Editor Toolbar, Editor > Save edits. Stop Editing.
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EDITING POINT EVENTS

el A

O N w

10.
11.

Label the data points shapefile and the point events theme so that they can be compared.
Editor Toolbar, Editor>Start Editing if necessary.
Zoom to the location where the point event is that needs to be moved.
On the HEM toolbar, set Task to Update Point Event and the Target to Point_Events:
b *
Select the HEM select event tool.

Draw a box around the point to update.
A candidate form will appear with selected events listed.
Select the feature in the candidate list and click update button.

Using the HEM Sketch Tool, specify the new location of the event. i
Editor Toolbar, Editor > Save Edits.

Editor Toolbar, Editor > Stop Editing

Note: The labeling will not update until editing is stopped.

Note: If there are multiple points at a location, open the identify box and identify on the
point of interest before selecting with the HEM select tool. You will need to reference the
ID.

DELETE POINT EVENTS

MAKE CERTAIN THAT ONLY THE POINT EVENT YOU ARE INTERESTED IN IS SELECTED. Other features
can be deleted by mistake.

w N e

O N U R
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Editor Toolbar, Editor>Start Editing if necessary.

Zoom to the location where the point event is that needs to be deleted.

On the HEM toolbar, set Task to Delete Point Event and the Target to Point_Events:
b #

Activate the HEM Select Event tool.

Click one of the points.

Select the event in the candidate form and click the delete button
Save Edits
Stop Editing
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Canal Name: Orig. # Points:

Scale Points Referenced Select Route

1:1000

1:5,000

1:25,000

1:125,000

1:625,000

1:3,125,000
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